CenterIM4 Requirements

From CenterIM
Jump to: navigation, search


Working versions

  • autoconf-2.59 or 2.61
  • automake-1.7 or 1.10
  • gettext-0.16.1


Package configuration

For building on Debian (Etch and up) based machines (including Ubuntu Feisty Fawn and up)

  • libgpgme11-dev libgpgme11
  • automake1.10
  • libgnutls-dev libgnutls13
  • autoconf
  • libncurses5 libncurses5-dev
  • gettext
  • gcc-4.1
  • git (only needed if you want to compile directly from git)
  • liblzo1 liblzo-dev
  • libcurl3-openssl-dev
  • g++ (Debian needs this compatibility packages, as configure doesn't recognize gcc's c++ capabilities)
  • libtool (for autogen.sh - mob branch only)
  • cvs (for autogen.sh - needed for compiling directly from git only)


To be able to build on from git using a clean Debian Etch, install this package list. Type this as root:

aptitude install build-essential libgpgme11-dev libgpgme11 automake libgnutls-dev libgnutls13 \
autoconf libncurses5 libncurses5-dev gettext git-core liblzo1 liblzo-dev libcurl3-openssl-dev libtool cvs

To be able to build on from git using a clean Ubuntu 9.10 Karmic Koala, install this package list. Type this:

sudo apt-get install build-essential libgpgme11-dev libgpgme11 automake libgnutls-dev autoconf \
libncurses5 libncurses5-dev gettext git-core libcurl4-openssl-dev libtool cvs

For building snap- and mobshots omit git-core and cvs

Fedora 13 package list

This is an incomplete list for fedora 13.

  • libcurl-devel
  • gpgme-devel
  • gpgme
yum install libcurl-devel gpgme-devel gpgme

Cygwin / win32

For details on how you can compile on a win32 system, see the cygwin page.